summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRedrield2017-08-15 19:19:09 -0400
committerRedrield2017-08-15 19:19:09 -0400
commitf2c1c2be8517099ba17561f52b1e9047fd9e88de (patch)
treeabe5b2850dd47a2e8781ddb47f630f9c99afd789 /PKGBUILD
downloadaur-f2c1c2be8517099ba17561f52b1e9047fd9e88de.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d5439a42041
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Rhys Kenwell <redrield+aur@gmail.com>
+pkgname=heroku-cli
+pkgver=6.13.13
+pkgrel=1
+pkgdesc="a tool for creating and managing Heroku apps from the command line"
+arch=('i686' 'x86_64')
+url="devcenter.heroku.com/articles/heroku-cli"
+license=('custom' 'ISC')
+optdepends=('git: Deploying to Heroku')
+provides=('heroku-cli')
+conflicts=('heroku-cli' 'heroku-client-standalone' 'heroku-toolbelt' 'ruby-heroku')
+source_x86_64=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x64.tar.gz')
+source_i686=('https://cli-assets.heroku.com/heroku-cli/channels/stable/heroku-cli-linux-x86.tar.gz')
+md5sums_i686=('d946005de9ea2feca3f709504ea13094')
+md5sums_x86_64=('38f6a4f6d748f7fbc43c58374e3fee62')
+
+prepare() {
+ cd "${srcdir}"
+ dir=$(find . -type d -regextype sed -regex ".*/heroku-cli-.*" | head -n1)
+ mv $dir heroku-cli
+}
+
+package() {
+ cd "${srcdir}"
+
+ install -dm 755 "${pkgdir}"/opt
+ install -dm 755 "${pkgdir}"/usr/bin
+ install -Dm 644 heroku-cli/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ mv heroku-cli "${pkgdir}"/opt/heroku-cli
+ ln -s /opt/heroku-cli/bin/heroku "${pkgdir}"/usr/bin/heroku
+}