summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvlad2015-07-08 15:36:14 +0300
committervlad2015-07-08 15:36:14 +0300
commit3450089af22d4ccb6b40dfbeb5602174230be62c (patch)
tree093dc0c492e291109edd6d3ee6b53d7107c4c20a /PKGBUILD
downloadaur-3450089af22d4ccb6b40dfbeb5602174230be62c.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..167598cda209
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: pisuka <tekmon@gmail.com>
+pkgname=heroku-toolbelt
+pkgver=3.36.5
+pkgrel=1
+pkgdesc="Everything you need to get started using Heroku (including foreman)"
+arch=(any)
+url="https://toolbelt.heroku.com"
+license=(MIT APACHE RUBY PerlArtistic GPL custom)
+groups=()
+depends=("ruby>=1.9")
+makedepends=("ruby-bundler")
+optdepends=(git)
+provides=()
+conflicts=(ruby-heroku ruby-foreman heroku-client)
+replaces=()
+backup=()
+options=()
+install=
+source=(Gemfile Gemfile.lock)
+md5sums=(0a2cce437aeb5097696a6f78cc4c3bb5 31cf02779f22ac6dc8e1fa894abbccd2)
+
+package() {
+ cd "$pkgdir"
+ mkdir -p "usr/lib/ruby/vendor_ruby/$pkgname" "usr/bin" "usr/share/man/man1"
+ cd "usr/lib/ruby/vendor_ruby/$pkgname"
+
+ #cp -R "$srcdir/heroku-client" .
+ cp -L "$srcdir"/Gemfile* .
+
+ #find "heroku-client/bin" -maxdepth 1 -type f -executable -printf "/usr/lib/ruby/vendor_ruby/$pkgname/heroku-client/bin/%f\n" | xargs ln -st "$pkgdir/usr/bin/"
+
+ bundle install --standalone --deployment --binstubs="$pkgdir/usr/bin"
+
+ cd "$pkgdir"
+
+ find "usr/bin" -type f ! -name heroku ! -name foreman -execdir rm "{}" +
+
+ find "usr/lib/ruby/vendor_ruby/heroku-toolbelt/vendor/bundle/ruby" -path "*/gems/*/man/*" -exec ln -st "usr/share/man/man1/" "/{}" \;
+}
+
+# vim:set ts=2 sw=2 et: