summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatrix2023-08-22 10:42:25 +0100
committerMatrix2023-08-22 10:42:25 +0100
commitbee2aa0015cafa1974c10be5468342306ac7dc9f (patch)
tree586b57a4743b0a979f318cac409682d70ef1f5f7 /PKGBUILD
parent418b2203534e0a789200aa08314f2279efceaf80 (diff)
downloadaur-bee2aa0015cafa1974c10be5468342306ac7dc9f.tar.gz
Optimisations
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 17 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c22e13271da4..95b857317779 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,49 +2,39 @@
pkgname=hexchat-theme-manager-git
_root_pkgname=hexchat
-pkgver=2.16.1.r33.g6155c183
-pkgrel=1
+pkgver=2.16.1.r34.gcda96128
+pkgrel=2
pkgdesc='A simple application to manage HexChat themes'
arch=('i686' 'x86_64')
url='https://hexchat.github.io'
license=('GPL')
depends=('mono' 'hexchat>=2.16.1')
-makedepends=('monodevelop' 'meson')
+makedepends=('meson' 'msbuild')
source=("git+https://github.com/hexchat/hexchat.git")
sha256sums=('SKIP')
-_files=(
- "usr/share/applications/io.github.Hexchat.ThemeManager.desktop"
- "usr/share/mime/packages/io.github.Hexchat.ThemeManager.xml"
- "usr/bin/thememan.exe"
- "usr/bin/thememan"
-)
-
pkgver() {
- cd "${srcdir}/$_root_pkgname"
+ cd "${srcdir}/${_root_pkgname}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}"
- arch-meson $_root_pkgname build -Dtheme-manager=true
- meson compile -C build
+ cd "${srcdir}/${_root_pkgname}/src/htm"
+
+ _platform="x86"
+ if [ "${CARCH}" == 'x86_64' ]; then
+ _platform="x64"
+ sed -i "s/x86/x64/g" htm.csproj
+ fi
+
+ msbuild /property:Configuration=Release /property:Platform="${platform}"
}
package() {
- cd "${srcdir}"
- meson install -C build --destdir "${srcdir}/full" # It also builds stuff already in hexchat package
-
- # Only install stuff not in hexchat package
- install -d "${pkgdir}/usr/bin"
- install -d "${pkgdir}/usr/share/mime/packages"
- install -d "${pkgdir}/usr/share/applications"
-
- for file in "${_files[@]}"
- do
- echo $file
- cp "${srcdir}/full/${file}" "${pkgdir}/${file}"
- done
+ install -Dm755 "${srcdir}/${_root_pkgname}/src/htm/obj/${_platform}/Release/thememan.exe" "${pkgdir}/usr/bin/thememan.exe"
+ install -Dm755 "${srcdir}/${_root_pkgname}/src/htm/thememan.in" "${pkgdir}/usr/bin/thememan"
+ install -Dm644 "${srcdir}/${_root_pkgname}/data/misc/io.github.Hexchat.ThemeManager.desktop.in" "${pkgdir}/usr/share/applications/io.github.Hexchat.ThemeManager.desktop"
+ install -Dm644 "${srcdir}/${_root_pkgname}/data/misc/io.github.Hexchat.ThemeManager.xml" "${pkgdir}/usr/share/mime/packages/io.github.Hexchat.ThemeManager.xml"
}