summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsumt2016-05-31 07:59:20 +0300
committersumt2016-05-31 07:59:20 +0300
commit8cde2fa2626f11e583985c4cac41171406323c76 (patch)
tree29a66147e6bd62c2591156b46d12e03b59e23e02 /PKGBUILD
downloadaur-8cde2fa2626f11e583985c4cac41171406323c76.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9607b646a2ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: sumt <sci.fi: sumt>
+# Contributor: Jesse Jaara <gmail.com: jesse.jaara>
+# Contributor: Janne Haapsaari <iki.fi: haaja>
+
+pkgname=hfstospell-git
+pkgver=0.4.1.r5.g6d359c0
+pkgrel=1
+pkgdesc='Helsinki Finite-State Transducer Technology (HFST) tools'
+arch=('i686' 'x86_64')
+url='https://hfst.github.io/'
+license=('APACHE')
+depends=('libxml++' 'libarchive' 'icu')
+makedepends=('git' 'sed')
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+options=(!libtool)
+source=('hfstospell-git::git+https://github.com/hfst/hfst-ospell.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package () {
+ cd "$pkgname"
+ make DESTDIR="${pkgdir}" install
+}