summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYen Chi Hsuan2015-08-21 01:14:46 +0800
committerYen Chi Hsuan2015-08-21 01:14:46 +0800
commit5c30f5f7555b07267db1e0f2b62a4fbc8bb8e50c (patch)
tree44543c0d03e3a3bac79ff6dbdde9a6c294b1b488 /PKGBUILD
parent2f0b7eaf941721726815e97d95a6f528afe29772 (diff)
downloadaur-hhvm-git.tar.gz
wangle is split as a standalone submodule
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4339c4885238..cd9a648e8e46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=hhvm
_github_addr=facebook/hhvm
pkgname=${_pkgname}-git
-pkgver=20150816
+pkgver=20150820
pkgrel=1
pkgdesc="Virtual Machine, Runtime, and JIT for PHP"
arch=('x86_64')
@@ -42,7 +42,8 @@ source=("git+https://github.com/$_github_addr" #1
"git+https://github.com/facebook/proxygen" #6
"git+https://github.com/facebook/mcrouter"
"git+https://github.com/google/re2"
- "git+https://github.com/webscalesql/webscalesql-5.6" #9
+ "git+https://github.com/webscalesql/webscalesql-5.6"
+ "git+https://github.com/facebook/wangle" #10
'hhvm.tmpfile'
'hhvm@.service'
'server.ini'
@@ -50,7 +51,7 @@ source=("git+https://github.com/$_github_addr" #1
'php_ini.patch')
backup=('etc/hhvm/server.ini' 'etc/hhvm/systemd-server.conf')
sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'c049b53f5ca7f8384d3b0a9d257018770b3a171f3b7ae8865cbb2c402a26b5e9'
'dddf4325926a41b3f1b5a41a1a42364ee463ab627f9d9b05ccf7c4660af3a51c'
'bca85e0445f3e26df65876c52e507aec8146cd31cce12c82846b55705529caed'
@@ -82,6 +83,7 @@ prepare() {
git config submodule.squangle/squangle.url "${srcdir}/squangle"
git config submodule.thrift/src.url "${srcdir}/fbthrift"
git config submodule.webscalesqlclient/webscalesql-5.6.url "${srcdir}/webscalesql-5.6"
+ git config submodule.wangle/src.url "${srcdir}/wangle"
git submodule update
}