summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYaohan Chen2015-06-20 22:37:26 -0400
committerYaohan Chen2015-06-20 22:37:26 -0400
commit63c3322f8ff491ad64090163b2a26bd6a8c19f6b (patch)
tree77a86d53e798acae7b1af3ab6ce7032b4a45b05b /PKGBUILD
downloadaur-63c3322f8ff491ad64090163b2a26bd6a8c19f6b.tar.gz
Initial commit using aur2git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be74964428f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+
+pkgname=hib-dlagent-git
+_appname=hib-dlagent
+pkgver=0.7.1.g42adb30
+pkgrel=1
+pkgdesc='Tool to download Humble Indie Bundle binaries by file name (uses PhantomJS to support new Humble Bundle site)'
+arch=('any')
+url='https://github.com/hagabaka/hib-dlagent'
+license=('GPL2')
+depends=('curl' 'python-humblebundle-git')
+makedepends=('git')
+provides=("$_appname")
+conflicts=("$_appname")
+optdepends=('gnome-keyring-query: encrypted account password support')
+source=('git+https://github.com/hagabaka/hib-dlagent.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_appname"
+ git describe --tags | sed 's/^v//; s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_appname"
+ DEST="$pkgdir" ./install.sh
+}