summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Gerecke2015-06-23 15:21:49 -0700
committerJason Gerecke2015-06-23 15:21:49 -0700
commitbacae62a22e97ba135ef477c18d08a9a4e0fc438 (patch)
tree403089ae567a8091ecf2df918437d354206d219c /PKGBUILD
downloadaur-bacae62a22e97ba135ef477c18d08a9a4e0fc438.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..248f457cfa61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jason Gerecke <killertofu@gmail.com>
+
+pkgname=hid-replay-git
+pkgver=0.7.1.r0.g241710c
+pkgrel=1
+pkgdesc="HID event recorder and utilities."
+arch=('i686' 'x86_64')
+url="https://github.com/bentiss/hid-replay/"
+license=('GPL2')
+depends=('glibc')
+optdepends=(
+ 'xmlto: build manpages'
+ 'asciidoc: build manpages'
+)
+makedepends=('git')
+provides=('hid-replay')
+conflicts=('hid-replay')
+options=('!libtool')
+source=("$pkgname"::git://github.com/bentiss/hid-replay.git#branch=master)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed -r 's/^v//;s/-/.r/; s/-/./'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+