summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Harting2024-01-13 15:39:57 +0100
committerGiovanni Harting2024-01-13 15:39:57 +0100
commite18bb86bfc41bec4a525911bed1922550a65490f (patch)
tree28df728e22dcf84d454a0fbda1596d554388c45f /PKGBUILD
parent15c1c2dd24329cb8bfa9c4930b194c93fa170364 (diff)
downloadaur-e18bb86bfc41bec4a525911bed1922550a65490f.tar.gz
upgpkg: hide-client 0.9.8-2
fixed sed patching non-existent file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9c3510feac9..daf0fc758005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname=hide-client
_pkgname=hide.client.linux
pkgver=0.9.8
-pkgrel=1
+pkgrel=2
pkgdesc="Hide.me CLI VPN client for Linux"
arch=(x86_64 aarch64 armv7h armv6h)
url="https://github.com/eventure/hide.client.linux"
-license=('GPL2')
+license=(GPL2)
depends=(glibc)
makedepends=(go)
-backup=("etc/hide.me/config")
+backup=('etc/hide.me/config')
source=("https://github.com/eventure/$_pkgname/archive/$pkgver.zip")
b2sums=('ed3bc28dbc40288bfbd0ea9adb643c484e9a19bce582719834a65749ae1494d5c7c32685a1feadd6eecccc1d516d9ccaf8297192a2b464b919fde586368219ac')
@@ -20,7 +20,7 @@ prepare() {
sed -e "s|CA.pem|/usr/share/hide.me/CA.pem|" \
-e "s|accessToken.txt|/etc/hide.me/accessToken.txt|" \
- -i configuration/configuration.go
+ -i configuration.go
sed -e "s|/opt/hide.me/hide.me|/usr/bin/hide.me|" \
-e "s|WorkingDirectory=/opt/hide.me|WorkingDirectory=/etc/hide.me|" \
@@ -54,7 +54,9 @@ package() {
install -Dm644 -t "$pkgdir"/usr/share/hide.me CA.pem
# For (system-wide) accessToken.txt
- install -dm750 "$pkgdir"/etc/hide.me
+ install -dm755 "$pkgdir"/etc/hide.me
install -Dm644 -t "$pkgdir"/etc/hide.me config
install -Dm644 -t "$pkgdir"/usr/lib/systemd/system hide.me@.service
}
+
+# vim:set ts=2 sw=2 et: