summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomasz Pakuła2023-11-19 10:16:51 +0100
committerTomasz Pakuła2023-11-19 10:16:51 +0100
commitf01b890c52183c0c8a06adbda51b1830b5aa81d6 (patch)
treee9077b4c3d168f09ed0a7f8b32ffaf18451289c9 /PKGBUILD
parent70ad6ba8f86de7c9622bf54f9824123eb06a3efa (diff)
downloadaur-f01b890c52183c0c8a06adbda51b1830b5aa81d6.tar.gz
Add axis hack patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 18 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1afd7284796b..16b01b120474 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,29 @@ arch=('x86_64')
url="https://github.com/Lawstorant/hid-logitech-hidpp"
license=('GPL2')
depends=(dkms)
-makedepends=(git)
-source=(git+https://github.com/Lawstorant/hid-logitech-hidpp)
-sha256sums=('SKIP')
+makedepends=(
+ git
+ gcc
+ glibc
+)
+source=(
+ git+https://github.com/Lawstorant/hid-logitech-hidpp
+ axis-hack.patch
+)
+sha256sums=(
+ 'SKIP'
+ 'addbedca432c213cc58642dca94e55209098d44fb967d0f2fcd1ec83a433a624'
+)
pkgver() {
cd "$srcdir/$_reponame"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+
+prepare() {
+ cd "$srcdir/$_reponame"
+ git apply -3 ../axis-hack.patch
+}
package() {
cd "$srcdir/$_reponame"