summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn-Gee2019-04-18 00:53:28 -0700
committerJohn-Gee2019-04-18 00:53:28 -0700
commitbae5d13fa855477dfc1f8d8970a6af68d77d431f (patch)
tree09f851c38728028df6379faf515a1c3ff435dd09 /PKGBUILD
parenta63d16a520b552af009681cc09869fca9e4b403c (diff)
downloadaur-bae5d13fa855477dfc1f8d8970a6af68d77d431f.tar.gz
Updated to v107r2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19bef08611c4..e886e0eaf922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: gee
pkgname=higan-bsnes
-pkgver=107.1
-pkgverR=107r1
+pkgver=107.2
+pkgverR=107r2
pkgrel=1
pkgdesc='Nintendo SNES emulator, faster flavor of higan'
arch=('x86_64')
@@ -14,18 +14,26 @@ depends=('alsa-lib' 'cairo' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk2'
'libudev.so')
conflicts=('bsnes' 'bsnes-classic')
source=("https://download.byuu.org/bsnes_v${pkgverR}-source.7z")
-sha256sums=('8649491111ecf257daec4637d7c238ebed534860a16bcfa139d7bca4c2629fbf')
+sha256sums=('527dbbd9957465183a14c2e8ef8767b493d8542b6b8f10e5fd5f99eb46e94bb0')
+
+#root issue in package
+prepare() {
+ cd bsnes_v${pkgverR}-source/bsnes/target-bsnes
+ sed -i "37,38d" GNUmakefile
+ sed -i '37s/^.....//' GNUmakefile
+}
build() {
- cd bsnes_v${pkgverR}-source
+ cd bsnes_v${pkgverR}-source/bsnes
- make -C higan target=bsnes
+ make
}
package() {
- cd bsnes_v${pkgverR}-source
+ cd bsnes_v${pkgverR}-source/bsnes
+ make prefix="${pkgdir}/usr" install
- install -Dm 755 higan/out/bsnes -t "${pkgdir}"/usr/bin/
- install -Dm 644 higan/target-bsnes/resource/bsnes.desktop -t "${pkgdir}"/usr/share/applications/
- install -Dm 644 higan/target-bsnes/resource/bsnes.png -t "${pkgdir}"/usr/share/pixmaps/
+ #install -Dm 755 out/bsnes -t "${pkgdir}"/usr/bin/
+ #install -Dm 644 target-bsnes/resource/bsnes.desktop -t "${pkgdir}"/usr/share/applications/
+ #install -Dm 644 target-bsnes/resource/bsnes.png -t "${pkgdir}"/usr/share/pixmaps/
}