summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn-Gee2019-03-08 08:09:44 -0800
committerJohn-Gee2019-03-08 08:09:44 -0800
commitf0d5bea3a79606e8761db7fd672c036ba1de3dff (patch)
treed53e554b5ee263309bd42094b25885523986ae02 /PKGBUILD
downloadaur-f0d5bea3a79606e8761db7fd672c036ba1de3dff.tar.gz
First pkg (2nd time?)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42002fb8efce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: gee
+
+pkgname=higan-bsnes
+pkgver=107
+pkgrel=2
+pkgdesc='Nintendo SNES emulator, faster flavor of higan'
+arch=('x86_64')
+url='http://byuu.org/'
+license=('GPL3')
+depends=('alsa-lib' 'cairo' 'gcc-libs' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk2'
+ 'gtksourceview2' 'libao' 'libgl' 'libpulse' 'libx11' 'libxext' 'libxv'
+ 'openal' 'pango' 'sdl'
+ 'libudev.so')
+conflicts=('bsnes')
+source=("https://download.byuu.org/bsnes_v${pkgver}-source.7z")
+sha256sums=('7b7fa745ce593f9912ce116bdf009cd2e70eb034cd7186264c4abedb87a5da36')
+
+build() {
+ cd bsnes_v${pkgver}-source
+
+ make -C higan target=bsnes
+}
+
+package() {
+ cd bsnes_v${pkgver}-source
+
+ install -Dm 755 higan/out/bsnes -t "${pkgdir}"/usr/bin/
+ install -Dm 644 higan/target-bsnes/resource/bsnes.desktop -t "${pkgdir}"/usr/share/applications/
+ install -Dm 644 higan/target-bsnes/resource/bsnes.png -t "${pkgdir}"/usr/share/pixmaps/
+}