summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-10 18:36:08 +0300
committerIgor Dyatlov2021-08-10 18:36:08 +0300
commit33512ce828f5475f17b99f97d99d06fa64ff3363 (patch)
tree35d2793318b565dab71bc86b87a7c2bb83e711aa /PKGBUILD
parent61d25d989287830c10496f743d32d2f4006f9f68 (diff)
downloadaur-33512ce828f5475f17b99f97d99d06fa64ff3363.tar.gz
Updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD60
1 files changed, 55 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4705df04e5e2..ab415065e5e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,67 @@
pkgname=highscore
pkgver=40.0
-pkgrel=2
+pkgrel=3
pkgdesc="Highscore is a retro gaming application for the GNOME desktop"
-arch=('any')
+arch=('x86_64')
url="https://gitlab.gnome.org/World/highscore"
license=('GPL3')
depends=('tracker' 'grilo' 'grilo-plugins' 'glib2' 'libsass' 'sassc' 'gtk3' 'libadwaita' 'libhandy' 'libevdev' 'libmanette' 'libarchive' 'retro-gtk' 'librsvg' 'libsoup' 'sqlite' 'libxml2')
-makedepends=('meson' 'gcc' 'vala')
-optdepends=('libretro')
+makedepends=('cmake' 'meson' 'gcc' 'vala')
+optdepends=('kodi-addon-game-libretro: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-beetle-psx: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-desmume: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-flycast: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-gambatte: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-melonds: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-mgba: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-mupen64plus-nx: Nintendo64 mupen64plus-next for kodi'
+ 'kodi-addon-game-libretro-nestopia: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-parallel-n64: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-scummvm: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-snes9x: Libretro wrapper for Kodis Game API'
+ 'kodi-addon-game-libretro-yabause: Libretro wrapper for Kodis Game API'
+ 'libretro-beetle-pce: NEC PC Engine/SuperGrafx/CD core'
+ 'libretro-beetle-pce-fast: NEC PC Engine/CD core'
+ 'libretro-beetle-psx: Sony PlayStation core'
+ 'libretro-beetle-psx-hw: Sony PlayStation core'
+ 'libretro-beetle-supergrafx: NEC SuperGrafx core'
+ 'libretro-blastem: Sega Mega Drive core'
+ 'libretro-bsnes: Super Nintendo Entertainment System cores'
+ 'libretro-bsnes2014: Super Nintendo Entertainment System cores'
+ 'libretro-bsnes-hd: Super Nintendo Entertainment System core'
+ 'libretro-citra: Nintendo 3DS core'
+ 'libretro-core-info: Libretro core info files'
+ 'libretro-desmume: Nintendo DS core'
+ 'libretro-dolphin: Nintendo GC/Wii core'
+ 'libretro-duckstation: Sony PlayStation core'
+ 'libretro-flycast: Sega Dreamcast core'
+ 'libretro-gambatte: Nintendo Game Boy/Game Boy Color core'
+ 'libretro-genesis-plus-gx: Sega MS/GG/MD/CD core'
+ 'libretro-kronos: Sega Saturn core'
+ 'libretro-melonds: Nintendo DS core'
+ 'libretro-mesen: Nintendo Entertainment System core'
+ 'libretro-mesen-s: Super Nintendo Entertainment System core'
+ 'libretro-mgba: Nintendo Game Boy Advance core'
+ 'libretro-mupen64plus-next: Nintendo 64 core'
+ 'libretro-nestopia: Nintendo Entertainment System core'
+ 'libretro-overlays: Collection of overlays for libretro'
+ 'libretro-parallel-n64: Nintendo 64 core'
+ 'libretro-pcsx2: Sony PlayStation 2 core'
+ 'libretro-picodrive: Sega MS/MD/CD/32X core'
+ 'libretro-play: Sony PlayStation 2 core'
+ 'libretro-ppsspp: Sony PlayStation Portable core'
+ 'libretro-retrodream: Sega Dreamcast core'
+ 'libretro-sameboy: Nintendo Game Boy/Game Boy Color core'
+ 'libretro-scummvm: ScummVM core'
+ 'libretro-shaders-slang: Collection of shaders for libretro'
+ 'libretro-snes9x: Super Nintendo Entertainment System core'
+ 'libretro-yabause: Sega Saturn core'
+ 'retroarch: Reference frontend for the libretro API')
+checkdepends=('appstream-glib')
replaces=('gnome-games')
source=("$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('SKIP') #autofill using updpkgsums
+sha256sums=('5d9048c48b85e2fe54e09440548bf1e7e991809f5bdbb9f09ecffd790e44e2dd')
build() {
arch-meson "$pkgname-$pkgver" build