summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-02-28 11:49:05 -0500
committeracxz2020-02-28 11:49:05 -0500
commit48ed3788b2d74605bfb1e381e43054262eaf9f98 (patch)
tree010887c335523414975e3d357eaa8216aead01e7 /PKGBUILD
downloadaur-48ed3788b2d74605bfb1e381e43054262eaf9f98.tar.gz
create hip-nvcc package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc70ab19dac1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=hip-nvcc
+pkgver=3.1.0
+pkgrel=1
+pkgdesc="Heterogeneous Interface for Portability ROCm"
+arch=('x86_64')
+url="https://github.com/ROCm-Developer-Tools/HIP"
+license=('custom')
+makedepends=('libelf' 'git' 'cmake' 'cuda')
+provides=('hip')
+conflicts=('hip')
+_dir="HIP-roc-${pkgver}"
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ROCm-Developer-Tools/HIP/archive/roc-${pkgver}.tar.gz")
+sha256sums=('3e7b7ef508f4c0d34756104936bc25eaffe419415013c93da72244aac199ae91')
+
+build() {
+ mkdir -p "${_dir}/build"
+ cd "${_dir}/build"
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/hip \
+ ..
+ make
+}
+
+package() {
+ cd "${_dir}/build"
+
+ make DESTDIR="$pkgdir" install
+
+ install -d "$pkgdir/etc/ld.so.conf.d"
+ cat << EOF > "$pkgdir/etc/ld.so.conf.d/hip.conf"
+/opt/rocm/hip/lib
+EOF
+}