summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneeshy2020-03-03 23:55:45 -0500
committerneeshy2020-03-07 14:29:30 -0500
commit9a5befb3083060e735644d4e656e5cdfcb5dfeae (patch)
tree6c20350ca31a2c3e6d9212ebb2855cb29c617146 /PKGBUILD
parent48ed3788b2d74605bfb1e381e43054262eaf9f98 (diff)
downloadaur-9a5befb3083060e735644d4e656e5cdfcb5dfeae.tar.gz
Cleanup
Consistent style across project Remove extraneous dependencies Update packages Update checksums and .SRCINFO Specify proper license Fix prefixes Prefer make to ninja Much more TODO: miopen, rocm-cmake{,-git}, rock-dkms{,-git}, Remove duplicates in makedepends and depends git submodules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc70ab19dac1..e91f112a030c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,25 @@ pkgrel=1
pkgdesc="Heterogeneous Interface for Portability ROCm"
arch=('x86_64')
url="https://github.com/ROCm-Developer-Tools/HIP"
-license=('custom')
-makedepends=('libelf' 'git' 'cmake' 'cuda')
+license=('MIT')
+makedepends=('libelf' 'cmake' 'cuda')
provides=('hip')
conflicts=('hip')
-_dir="HIP-roc-${pkgver}"
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/ROCm-Developer-Tools/HIP/archive/roc-${pkgver}.tar.gz")
+source=("https://github.com/ROCm-Developer-Tools/HIP/archive/roc-$pkgver.tar.gz")
sha256sums=('3e7b7ef508f4c0d34756104936bc25eaffe419415013c93da72244aac199ae91')
build() {
- mkdir -p "${_dir}/build"
- cd "${_dir}/build"
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/opt/rocm/hip \
- ..
+ "$srcdir/HIP-roc-$pkgver"
make
}
package() {
- cd "${_dir}/build"
+ cd "$srcdir/build"
make DESTDIR="$pkgdir" install