summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2020-11-29 16:40:39 +0100
committerAkash Patel2020-11-29 16:00:48 +0000
commitbcd934d9dce107efd30a8ff67c8cfa328928d7f9 (patch)
tree89660fdff1f9f06504d7e76e785416a6cd7ae142 /PKGBUILD
parentfe1a954df5aa8bca10e1907a760b364a59a629dd (diff)
downloadaur-bcd934d9dce107efd30a8ff67c8cfa328928d7f9.tar.gz
[hip-rocclr] Link hipVersion file to /opt/rocm/bin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c58a1859f23c..a6b7303184fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=hip-rocclr
pkgver=3.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Heterogeneous Interface for Portability ROCm"
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/Installation_Guide/HIP.html'
@@ -40,6 +40,10 @@ build() {
package() {
DESTDIR="$pkgdir" make -C build install
+ # clang from llvm-amdgpu may look for hipVersion in a different directory
+ install -d "$pkgdir/opt/rocm/bin"
+ ln -s '/opt/rocm/hip/bin/.hipVersion' "$pkgdir/opt/rocm/bin/.hipVersion"
+
# add links (hipconfig is for rocblas with tensile)
install -d "$pkgdir/usr/bin"
local _fn