summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-12-13 15:58:55 +0100
committerTorsten Keßler2022-12-13 15:58:55 +0100
commit8ff80f7c2b520afe3a03c12caf1513099d6f349b (patch)
tree98f31a1261077cba5347381ddc46ff8c4cfd1686 /PKGBUILD
parentc01081fed40f78815766d45f7d75ad9755780793 (diff)
downloadaur-8ff80f7c2b520afe3a03c12caf1513099d6f349b.tar.gz
upgpkg: hipblas 5.4.0-1
Update to ROCm 5.4.0: * Simple test case to be run after installation that checks if the package is correctly configured and installed; * set cmake build type to None to comply with arch's cmake policy; * remove unneeded build flags; * update checksum and links to docu.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31ef4d3a94fa..f3bc133e369c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naether.markus@gmail.com>
pkgname=hipblas
-pkgver=5.3.0
+pkgver=5.4.0
pkgrel=1
pkgdesc='ROCm BLAS marshalling library'
arch=('x86_64')
url='https://hipblas.readthedocs.io/en/latest/'
license=('MIT')
depends=('hip' 'rocblas' 'rocsolver')
-makedepends=('cmake' 'gcc-fortran')
+makedepends=('rocm-cmake' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/hipBLAS'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('873d55749479873994679840906c4257316dfb09a6200411204ad4a8c2480565')
+sha256sums=('341d61adff8d08cbf70aa07bd11a088bcd0687fc6156870a1aee9eff74f3eb4f')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.4/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake \
-Wno-dev \
-B build \
-S "$_dirname" \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- -DBUILD_CLIENTS_SAMPLES=OFF \
- -DBUILD_CLIENTS_TESTS=OFF
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm
cmake --build build
}