summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-12-08 20:05:07 +0100
committerTorsten Keßler2022-12-08 20:07:59 +0100
commit5c7e309ce1b510dd4e385d29657299d1013b8710 (patch)
treeadef194a85d98740e1d64a405c1776e9b6eb86a3 /PKGBUILD
parent6b6745d5191234048cb7b494f0c8b2f87f5dc133 (diff)
downloadaur-5c7e309ce1b510dd4e385d29657299d1013b8710.tar.gz
upgpkg: hipsparse 5.4.0-1
Update to 5.4.0 release with: * simple test case to be called after package installation that checks if the package is correctly configured and installed; * upstream patch to remove git as dependency; * updated checksums.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 15 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccd573843f60..a3433f12c82d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,38 @@
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=hipsparse
-pkgver=5.3.0
+pkgver=5.4.0
pkgrel=1
pkgdesc='rocSPARSE marshalling library.'
arch=('x86_64')
url='https://hipsparse.readthedocs.io/en/latest/'
license=('MIT')
depends=('hip' 'rocsparse')
-makedepends=('cmake' 'git' 'gcc-fortran')
+makedepends=('rocm-cmake' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/hipSPARSE'
-source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('691b32b916952ed9af008aa29f60cc190322b73cfc098bb2eda3ff68c89c7b35')
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
+ "hipsparse-no-git.patch::$_git/commit/23704c1257747f325a1f3db4e9c35f2d6ba724ad.patch")
+sha256sums=('47420d38483c8124813b744971e428a0352c83d9b62a5a50f74ffa8f9b785b20'
+ 'SKIP')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
+prepare() {
+ cd "$_dirname"
+ patch -Np1 -i "$srcdir/hipsparse-no-git.patch"
+}
+
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.4/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
HIP_PATH=/opt/rocm \
cmake \
-Wno-dev \
-B build \
-S "$_dirname" \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DBUILD_CLIENTS_SAMPLES=OFF \
- -DBUILD_CLIENTS_TESTS=OFF
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm
cmake --build build
}
@@ -38,5 +44,5 @@ package() {
echo "/opt/rocm/$pkgname/lib" > "$pkgname.conf"
install -Dm644 "$pkgname.conf" "$pkgdir/etc/ld.so.conf.d/$pkgname.conf"
- install -Dm644 "$srcdir/hipSPARSE-rocm-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_dirname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}