summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-06-26 09:12:01 -0400
committeracxz2020-06-26 09:12:01 -0400
commit62803a7471857ad8004bccb936cf8c59ce619c73 (patch)
tree71481cbd80ddf105a9ecf7d48760cdfb387867a9 /PKGBUILD
parent87caa1cb4369b0da4368414331a94099a2af3708 (diff)
downloadaur-62803a7471857ad8004bccb936cf8c59ce619c73.tar.gz
[hipsparse] use c++20 and fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5da425de6bfc..6371594598af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: Markus Näther <naetherm@informatik.uni-freiburg.de>
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
pkgname=hipsparse
pkgver=3.5.0
-pkgrel=1
+pkgrel=2
pkgdesc='rocSPARSE marshalling library.'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipsparse'
@@ -9,12 +11,23 @@ license=('MIT')
depends=('hip-rocclr' 'rocsparse')
makedepends=('cmake' 'git' 'rocminfo')
_git='https://github.com/ROCmSoftwarePlatform/hipSPARSE'
-source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('fa16b2a307a5d9716066c2876febcbc1cef855bf0c96d235d2d8f2206a0fb69d')
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
+ "fix_hcc_compress.patch::$_git/commit/e79985dccde22d826aceb3badfc643a3227979d2.patch"
+ "fix_nvcc_compress.patch::$_git/commit/530047af4a0f437dafc02f76b3a17e3b1536c7ec.patch")
+sha256sums=('fa16b2a307a5d9716066c2876febcbc1cef855bf0c96d235d2d8f2206a0fb69d'
+ '6b7493f0caa1b8042ef43c1a4cee6584abeeb9319c53a79e8b2e558cd1076992'
+ 'db755df3ae712d33d4954b7d302d656b1bdc8f226c063ee701d3b4d835297686')
+
+prepare() {
+ cd ${srcdir}/hipSPARSE-rocm-$pkgver
+ patch --forward --strip=1 --input="${srcdir}/fix_hcc_compress.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix_nvcc_compress.patch"
+}
build() {
CXX=/opt/rocm/hip/bin/hipcc \
cmake -B build -Wno-dev \
+ -DCMAKE_CXX_STANDARD=20 \
-DCMAKE_INSTALL_PREFIX=opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DAMDDeviceLibs_DIR=/opt/rocm/lib/cmake/AMDDeviceLibs \
@@ -29,7 +42,7 @@ build() {
package() {
DESTDIR="$pkgdir" make -C build install
- install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/hipsparse.conf" << EOF
+ install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/hipsparse.conf" << EOF
/opt/rocm/hipsparse/lib
EOF
install -Dm644 "$srcdir/hipSPARSE-rocm-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"