summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-10-14 12:04:00 +0200
committerTorsten Keßler2022-10-14 12:04:00 +0200
commit6b6745d5191234048cb7b494f0c8b2f87f5dc133 (patch)
tree1d0bd7458c19899eef9b6a4cf9b685911d5ba379 /PKGBUILD
parente925169550c0e190c3259c03aae2e7a44d974c9a (diff)
downloadaur-6b6745d5191234048cb7b494f0c8b2f87f5dc133.tar.gz
upgpkg: hipsparse 5.3.0-1
* Follow cmake template from wiki * Update checksum and links to documentation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d253c3aaf28c..ccd573843f60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=hipsparse
-pkgver=5.2.3
+pkgver=5.3.0
pkgrel=1
pkgdesc='rocSPARSE marshalling library.'
arch=('x86_64')
@@ -13,27 +13,30 @@ depends=('hip' 'rocsparse')
makedepends=('cmake' 'git' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/hipSPARSE'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('f70d3deff13188adc4105ef3ead53510e4b54075b9ffcfe3d3355d90d4b6eadd')
+sha256sums=('691b32b916952ed9af008aa29f60cc190322b73cfc098bb2eda3ff68c89c7b35')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
- CXX=/opt/rocm/bin/hipcc \
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
HIP_PATH=/opt/rocm \
- cmake -Wno-dev -S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DBUILD_CLIENTS_SAMPLES=OFF \
- -DBUILD_CLIENTS_TESTS=OFF
- make
+ cmake \
+ -Wno-dev \
+ -B build \
+ -S "$_dirname" \
+ -DCMAKE_CXX_COMPILER=/opt/rocm/bin/hipcc \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DBUILD_CLIENTS_SAMPLES=OFF \
+ -DBUILD_CLIENTS_TESTS=OFF
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
+
+ echo "/opt/rocm/$pkgname/lib" > "$pkgname.conf"
+ install -Dm644 "$pkgname.conf" "$pkgdir/etc/ld.so.conf.d/$pkgname.conf"
- install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/hipsparse.conf" << EOF
-/opt/rocm/hipsparse/lib
-EOF
install -Dm644 "$srcdir/hipSPARSE-rocm-$pkgver/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}