diff options
author | Bret Comnes | 2024-02-19 13:49:45 -0800 |
---|---|---|
committer | Bret Comnes | 2024-02-19 14:09:14 -0800 |
commit | 769923a5351889c58069f5d512d797cd9a4be627 (patch) | |
tree | f04895c7ef6691cbbb3dc999ad6c82fd97bb3de9 /PKGBUILD | |
parent | af5ec929aa82ff9590dd908d20727f893262beac (diff) | |
download | aur-769923a5351889c58069f5d512d797cd9a4be627.tar.gz |
upgpkg: homebridge-config-ui-x 4.55.1-1
* Update to v4.55.1
* use npm tartballs for a dramatically quicker and more-reliable install.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 50 |
1 files changed, 11 insertions, 39 deletions
@@ -1,70 +1,42 @@ # Maintainer: George Rawlinson <george@rawlinson.net.nz> pkgname=homebridge-config-ui-x -pkgver=4.49.0 +pkgver=4.55.1 pkgrel=1 pkgdesc='Web-based management tool for Homebridge' arch=('any') url='https://github.com/oznu/homebridge-config-ui-x' license=('MIT') -depends=('homebridge' 'npm') -makedepends=('git') +depends=('homebridge' 'nodejs') +makedepends=('npm') options=('!emptydirs' '!strip') -_commit='bdb239bb699378b1a97e9baa4806405d05c7fcb1' source=( - "$pkgname::git+$url.git#commit=$_commit" + "https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz" 'systemd.service' 'tmpfiles.conf' 'sysusers.conf' ) install="$pkgname.install" -sha512sums=('SKIP' +sha512sums=('5e88f008e101e8bb09798b7a3456a45c6088b3d58503fc62ada5610b5475fbffdb40f9afd53d45dec66facfc69d544c12cac68c53dfb48c76dab4bacf294726b' '6a758eeea0cee8e262e9209226b3c4ff5e8982f8d3671bfb18287656eca71309694f3f9f11317ce80696991640fa277771ec21536546ea46d2565f64e08fff44' '68e756b0b6b78a53b1198bf630821abe470293c53ebd74d5a42acd589b41940920cfc949853695270f4b5de7c6e7e1b3d42d408694eec8551782a4ef163baeb1' 'a1722316d9c2e2130a3a7c808fc6570e0176863b72f0a8c511bd8a5a5a5a3c9064f22c25479ca43c856facdcc67d8c161feeefc1225e543471c73b693a493313') -b2sums=('SKIP' +b2sums=('e9021bd2ca6306da4ac0d2a8a1d9eda6530e4d5b3950aa95fb177d2191ac3dc00898e2935a5a724cb6bc807b8de988baefeaffb744431862eae21963b6f596b2' 'a0861270612dfe3ee33fab9fda23ab351625a76bfc006d44f39387c8b4fd7b67b7937d8c6dc94dbb584fe6e3fa657fd8754d3c823f2a2dd3d93f210d6b5d8102' 'c60e965907e85b4a6dac12b60419b5446085794bdbdba0221c41e7557ff520c3688ff79b1219e17ac982d585f2cf616140717b44f8ad2a5e5a72fd360617be65' '17039410c1e7aa8efd781a6a9acd31084a632998f0ea57f0df40fa028d12527b24bec71fdf28691b8e23fbfdef10c9b327875477ee113ffa9ad022d84a35552e') -pkgver() { - cd "$pkgname" - - git describe --tags | sed 's/^v//' -} - -build() { - cd "$pkgname" - - # NOTE: package is built this way because the dist/ directory is not - # included in the source, only in npm source due to a prepublish script - # which does not get installed correctly if the npm source is used. - - # ensure npm is quiet - local NPM_FLAGS=(--no-audit --no-fund --no-update-notifier) - - # install dependencies - npm install "${NPM_FLAGS[@]}" - - # install subproject dependencies - pushd ui - npm install "${NPM_FLAGS[@]}" - popd - - # generate dist dir - npm run build "${NPM_FLAGS[@]}" - - # generate tarball - npm pack -} - package() { - cd "$pkgname" + local NPM_FLAGS=(--no-audit --no-fund --no-update-notifier) npm install \ --global \ --prefix "$pkgdir/usr" \ + "${NPM_FLAGS[@]}" \ "$pkgname-$pkgver.tgz" + # remove a non-runtime file that kills the packaging step + rm -r "$pkgdir/usr/lib/node_modules/$pkgname/node_modules/@fastify/send/test/fixtures/snow ☃/" + # npm gives ownership of ALL FILES to build user # https://bugs.archlinux.org/task/63396 chown -R root:root "$pkgdir" |