summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarek Kubica2010-12-04 22:12:59 +0100
committerMarek Kubica2010-12-04 22:12:59 +0100
commitf4a329c63d80be6c7015f00c4d11f6098283ffdc (patch)
tree1ecb4a81b36e5f7fe9f688d12fcf2e6ff956d270 /PKGBUILD
downloadaur-f4a329c63d80be6c7015f00c4d11f6098283ffdc.tar.gz
Initial PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be68c848b024
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Leonidas <marek@xivilization.net>
+pkgname=homesick
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="A man's home is his castle. Never leave your dotfiles behind."
+arch=(any)
+url="http://github.com/technicalpickles/homesick"
+license=('MIT')
+depends=(ruby ruby-thor)
+# well, rubygems is part of the ruby package nowadays, but *shrug*
+makedepends=(rubygems)
+source=(http://rubygems.org/downloads/homesick-$pkgver.gem)
+noextract=(homesick-$pkgver.gem)
+md5sums=('27c8c96fb6b5c41f3edbec083f85bea5')
+
+build() {
+ cd $srcdir
+ # _gemdir is defined inside build() because if ruby[gems] is not installed on the system
+ # makepkg will barf when sourcing the PKGBUILD
+ local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+
+ gem install --ignore-dependencies -i "$pkgdir$_gemdir" homesick-$pkgver.gem
+}