summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2020-08-03 10:50:22 +0200
committerAlphaJack2020-08-03 10:52:26 +0200
commit161eeac29fa160bf6e6df0518ff5382468eeb844 (patch)
tree8df22d02447ea8840dd335851f639da0acb10481 /PKGBUILD
downloadaur-161eeac29fa160bf6e6df0518ff5382468eeb844.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..729027c40b34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname='horcrux-bin'
+pkgver='0.2'
+pkgrel=1
+pkgdesc="Split your file into encrypted horcruxes so that you don't need to remember a passcode"
+url='https://github.com/jesseduffield/horcrux/'
+license=('MIT')
+arch=('x86_64' 'i686' 'armv6h' 'aarch64')
+provides=('horcrux')
+conflicts=('horcrux')
+source_x86_64=('https://github.com/jesseduffield/horcrux/releases/download/v0.2/horcrux_0.2_Linux_x86_64.tar.gz')
+source_i686=('https://github.com/jesseduffield/horcrux/releases/download/v0.2/horcrux_0.2_Linux_32-bit.tar.gz')
+source_armv6h=('https://github.com/jesseduffield/horcrux/releases/download/v0.2/horcrux_0.2_Linux_armv6.tar.gz')
+source_aarch64=('https://github.com/jesseduffield/horcrux/releases/download/v0.2/horcrux_0.2_Linux_arm64.tar.gz')
+md5sums_x86_64=('619f6b101bff7a00570d028d1cea7d95')
+md5sums_i686=('1a790442363f0739f0a5c117365b3ec8')
+md5sums_armv6h=('8751bbbb60e70925773f3075b7122776')
+md5sums_aarch64=('2b874076bd22158b9199b664041db2bd')
+
+package() {
+ install -Dm755 "$srcdir/horcrux" "$pkgdir/usr/bin/horcrux"
+}
+
+