summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlphaJack2023-06-29 01:35:18 +0200
committerAlphaJack2023-06-29 01:35:18 +0200
commitf88d9a008092ec2c9ab8b34ba671b889355beb0b (patch)
tree6013eab1362900231a5d6409ef8705819d4ac85a /PKGBUILD
parent48430b9bc88460f284d8472ff677d38958ba5ed5 (diff)
downloadaur-horcrux-git.tar.gz
Added horcrux-ui as optdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5c207061ec2..a06246697651 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,15 @@
pkgname="horcrux-git"
pkgver=0.3.r16.g6575949
-pkgrel=1
+pkgrel=2
pkgdesc="Split your file into encrypted fragments so that you don't need to remember a passcode"
arch=("x86_64")
url="https://github.com/jesseduffield/horcrux"
license=("MIT")
+provides=("horcrux")
+conflicts=("horcrux-bin")
makedepends=("go")
+optdepends=("horcrux-ui: graphical user interface")
source=("git+$url")
sha256sums=("SKIP")
options=("!strip")
@@ -29,6 +32,6 @@ build(){
package(){
cd "horcrux"
- install -D -m 0755 "horcrux" "$pkgdir/usr/bin/horcrux"
- install -D -m 0644 "LICENSE" "$pkgdir/usr/share/licenses/horcrux/LICENSE"
+ install -D -m 755 "horcrux" "$pkgdir/usr/bin/horcrux"
+ install -D -m 644 "LICENSE" "$pkgdir/usr/share/licenses/horcrux/LICENSE"
}