summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJon Gjengset2017-07-03 13:06:07 -0400
committerJon Gjengset2017-07-03 13:06:07 -0400
commit608400fe5b0884512b5935b54f9e78135fb1194e (patch)
tree67a3b94eaf9ef2026fae31a10a60a9b92da46ffd /PKGBUILD
downloadaur-608400fe5b0884512b5935b54f9e78135fb1194e.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..896466ac5407
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
+pkgname=hotspot-git
+pkgver=r259.ddcce26
+pkgrel=1
+pkgdesc="The Linux perf GUI for performance analysis"
+arch=('any')
+url="https://github.com/KDAB/hotspot"
+license=('GPL')
+depends=('qt5-base>=5.6.0' 'libelf' 'elfutils' 'threadweaver' 'ki18n' 'kconfig' 'kitemviews' 'kcoreaddons' 'kitemmodels' 'kconfigwidgets')
+makedepends=('git' 'cmake>=3.1.0' 'extra-cmake-modules')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('hotspot::git+https://github.com/KDAB/hotspot.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build-hotspot
+ cd "${pkgname%-git}"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/build-hotspot"
+ cmake "-DCMAKE_INSTALL_PREFIX=$pkgdir/usr" "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/build-hotspot"
+ make install
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+ rm -rf "$pkgdir/usr/share/icons"
+}