summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Lindner2017-09-30 15:35:41 +0800
committerFlorian Lindner2017-09-30 15:35:41 +0800
commit837690b750c9dc0ac2c946f24bb273b1efbaacf1 (patch)
tree011b5c50396013efd93ac5648188ed9bd0aa0b86 /PKGBUILD
parentd6ff19f4c878ece03682be4e8d396439a23739ce (diff)
downloadaur-837690b750c9dc0ac2c946f24bb273b1efbaacf1.tar.gz
Use another method to determine the version.
Includes also tags, i.e. release names.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e14e99cfc0dc..8b01bb18a926 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@ source=('hotspot::git+https://github.com/KDAB/hotspot.git')
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${pkgname%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {