summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Lindner2021-11-18 20:06:21 +0100
committerFlorian Lindner2021-11-18 20:06:21 +0100
commitd02389ee745bf7b4e0d0e2f9717d425477980023 (patch)
tree03a3fd18ec0928fd4a7891c7f413c9106d0b3d0a /PKGBUILD
parent48ec67794c2a88da0fd6f689371147f1d9295c99 (diff)
downloadaur-d02389ee745bf7b4e0d0e2f9717d425477980023.tar.gz
As per request, use cmake --install and --build.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b34e2a49566..4b317a5c6ab8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jon Gjengset <jon@thesquareplanet.com>
pkgname=hotspot-git
-pkgver=v1.3.0.r104.gb95679b
+pkgver=v1.3.0.r152.g1906fb4
pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('any')
@@ -30,11 +30,11 @@ build() {
cd "${pkgname%-git}"
cmake . -DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTING=off
- make
+ cmake --build .
}
package() {
cd "${pkgname%-git}"
- make DESTDIR="${pkgdir}/" install
+ DESTDIR="${pkgdir}/" cmake --install .
desktop-file-install hotspot.desktop --dir="${pkgdir}/usr/share/applications/"
}