summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Lindner2017-09-30 16:03:13 +0800
committerFlorian Lindner2017-09-30 16:03:13 +0800
commitf0316b59c91d8940a01fe86cde053b4d95378075 (patch)
treebf676e7985e29dee158ca38c4f9564b10d21f911 /PKGBUILD
parent837690b750c9dc0ac2c946f24bb273b1efbaacf1 (diff)
downloadaur-f0316b59c91d8940a01fe86cde053b4d95378075.tar.gz
Change build process
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 12 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b01bb18a926..43162e72b6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,13 @@ pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('any')
url="https://github.com/KDAB/hotspot"
-license=('GPL')
+license=('GPL2')
depends=('qt5-base>=5.6.0' 'libelf' 'elfutils' 'threadweaver' 'ki18n' 'kconfig' 'kitemviews' 'kcoreaddons' 'kitemmodels' 'kconfigwidgets')
makedepends=('git' 'cmake>=3.1.0' 'extra-cmake-modules')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('hotspot::git+https://github.com/KDAB/hotspot.git')
-md5sums=('SKIP')
+source=("git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
@@ -21,21 +21,19 @@ pkgver() {
}
prepare() {
- cd "$srcdir"
- mkdir -p build-hotspot
- cd "${pkgname%-git}"
- git submodule update --init --recursive
+ cd "${pkgname%-git}"
+ git submodule update --init --recursive
}
build() {
- cd "$srcdir/build-hotspot"
- env CC=gcc CXX=g++ cmake "-DCMAKE_INSTALL_PREFIX=$pkgdir/usr" "$srcdir/${pkgname%-git}"
- make
+ cd "${pkgname%-git}"
+ env CC=gcc CXX=g++ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
}
package() {
- cd "$srcdir/build-hotspot"
- make install
- mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
- rm -rf "$pkgdir/usr/share/icons"
+ cd "${pkgname%-git}"
+ make DESTDIR="${pkgdir}/" install
+ mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib"
+ rm -rf "$pkgdir/usr/share/icons"
}