summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Lindner2020-11-20 14:12:12 +0100
committerFlorian Lindner2020-11-20 14:12:12 +0100
commitf1c311d260379d4fa2afeeadab4cb97cc0eab456 (patch)
tree9411ba53471bb0f72e90d79fa6ac97a2959dc3fc /PKGBUILD
parentc7cad65474219e3d405a292449fa7ab78ed919fd (diff)
downloadaur-f1c311d260379d4fa2afeeadab4cb97cc0eab456.tar.gz
Install .desktop file from upstream.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd07478961ec..844318a5a01f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Jon Gjengset <jon@thesquareplanet.com>
pkgname=hotspot-git
-pkgver=v1.2.0.r25.gc65a82f
+pkgver=v1.3.0.r28.g103fd82
pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('any')
url="https://github.com/KDAB/hotspot"
license=('GPL2')
depends=('qt5-base>=5.6.0' 'libelf' 'elfutils' 'threadweaver' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kcoreaddons' 'kitemmodels' 'kconfigwidgets' 'solid')
-makedepends=('git' 'cmake>=3.1.0' 'extra-cmake-modules')
+makedepends=('git' 'cmake>=3.1.0' 'extra-cmake-modules' 'desktop-file-utils')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+${url}.git")
@@ -34,4 +34,5 @@ build() {
package() {
cd "${pkgname%-git}"
make DESTDIR="${pkgdir}/" install
+ desktop-file-install hotspot.desktop --dir="${pkgdir}/usr/share/applications/"
}