summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlorian Lindner2021-01-18 19:48:14 +0100
committerFlorian Lindner2021-01-18 19:48:14 +0100
commitf993f66d19cfcc077b234613694062424e2f5c26 (patch)
tree2078b5adb874c51cb38d4bec4a22bd4eef291313 /PKGBUILD
parentb2cfe8ca43f2331b4b321873f3d8a8923725cc1b (diff)
downloadaur-f993f66d19cfcc077b234613694062424e2f5c26.tar.gz
Make rustc-demange support optional and dependency as optdepends.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9d7ba5fed2d..5b5f160c15d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Jon Gjengset <jon@thesquareplanet.com>
pkgname=hotspot-git
-pkgver=v1.3.0.r95.g8f786c8
+pkgver=v1.3.0.r96.g6141fff
pkgrel=1
pkgdesc="The Linux perf GUI for performance analysis"
arch=('any')
url="https://github.com/KDAB/hotspot"
license=('GPL2')
-depends=('qt5-base>=5.6.0' 'elfutils' 'kcoreaddons' 'kddockwidgets' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kitemmodels' 'kconfigwidgets' 'libelf' 'rustc-demangle' 'solid' 'threadweaver')
+depends=('elfutils' 'kcoreaddons' 'kddockwidgets' 'ki18n' 'kconfig' 'kio' 'kitemviews' 'kitemmodels' 'kconfigwidgets' 'libelf' 'qt5-base>=5.6.0' 'solid' 'threadweaver')
makedepends=('git' 'cmake>=3.1.0' 'extra-cmake-modules' 'desktop-file-utils')
+optdepends=('rustc-demangle>=0.1.18-2: rustc symbols demangling')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+${url}.git")
@@ -27,9 +28,7 @@ prepare() {
build() {
cd "${pkgname%-git}"
- cmake . -DCMAKE_INSTALL_PREFIX=/usr \
- -DRUSTC_DEMANGLE_INCLUDE_DIR=/usr/include/rustc-demangle \
- -DRUSTC_DEMANGLE_LIBRARY=/usr/lib/rustc-demangle/librustc_demangle.so
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
make
}