summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Waller2015-08-28 15:40:02 -0700
committerEric Waller2015-08-28 15:40:02 -0700
commit234dc0e2385f626f3069f7b524376de6af35de15 (patch)
tree277728e687c21227064ec2d5ad54681380aa09d7 /PKGBUILD
downloadaur-234dc0e2385f626f3069f7b524376de6af35de15.tar.gz
Initial release. This is not the same hpfall that had previously
ben in the Arch AUR. This version does not use /etc/hpfall.conf. It has also been patched to post fall events to the system log
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c10d4e9ea7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Eric Waller <ewwaller+aur gmail com>
+
+pkgname=hpfall-git
+pkgver=r5.be24a8b
+pkgrel=1
+pkgdesc="Disk protection for HP machines."
+arch=('x86_64' 'i686')
+url_name="github.com/srijan/hpfall.git"
+url="https://"${url_name}
+License=('GPL')
+depends=()
+makedepends=('git')
+md5sums=('SKIP' 3a6a193021fe5f3078f97b8c2a4c8538 ac946477d1996e68fa63792829fd8a97)
+
+source=("${pkgname}"::"git://"${url_name} 'log_to_syslog.patch' 'hpfall.service')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ cd "$srcdir/${pkgname}"
+ patch -R hpfall.c < ../log_to_syslog.patch
+}
+
+build() {
+ cd "$srcdir"/${pkgname}
+ make
+}
+
+package() {
+ install -Dm755 ${pkgname}/hpfall $pkgdir/usr/bin/hpfall
+ install -Dm755 ${pkgname}/../hpfall.service $pkgdir/usr/lib/systemd/system/hpfall.service
+
+} \ No newline at end of file