summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Waller2018-07-20 16:24:51 -0700
committerEric Waller2018-07-20 16:24:51 -0700
commit58eeb75d1f1440f34d3126615eae2df9b4d54df0 (patch)
tree58479d39c4b6fc81f7464cc27b657d23a0c7123f /PKGBUILD
parent234dc0e2385f626f3069f7b524376de6af35de15 (diff)
downloadaur-58eeb75d1f1440f34d3126615eae2df9b4d54df0.tar.gz
Fixed service file permissions (removed execute flags)
Fixed quoting of srcdir and pkgdir variables Improved url definition and source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c10d4e9ea7d..0d926aefb838 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,34 @@
pkgname=hpfall-git
pkgver=r5.be24a8b
-pkgrel=1
+pkgrel=2
pkgdesc="Disk protection for HP machines."
arch=('x86_64' 'i686')
-url_name="github.com/srijan/hpfall.git"
-url="https://"${url_name}
-License=('GPL')
-depends=()
+url="https://github.com/srijan/hpfall.git"
+license=('GPL2')
+depends=('glibc')
makedepends=('git')
md5sums=('SKIP' 3a6a193021fe5f3078f97b8c2a4c8538 ac946477d1996e68fa63792829fd8a97)
-source=("${pkgname}"::"git://"${url_name} 'log_to_syslog.patch' 'hpfall.service')
+source=("git+${url}" 'log_to_syslog.patch' 'hpfall.service')
pkgver() {
- cd "$srcdir/${pkgname}"
+ cd "${srcdir}/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare(){
- cd "$srcdir/${pkgname}"
+ cd "${srcdir}/${pkgname%-git}"
patch -R hpfall.c < ../log_to_syslog.patch
}
build() {
- cd "$srcdir"/${pkgname}
+ cd "${srcdir}/${pkgname%-git}"
make
}
package() {
- install -Dm755 ${pkgname}/hpfall $pkgdir/usr/bin/hpfall
- install -Dm755 ${pkgname}/../hpfall.service $pkgdir/usr/lib/systemd/system/hpfall.service
+ install -Dm755 "${pkgname%-git}/hpfall" "${pkgdir}/usr/bin/hpfall"
+ install -Dm644 hpfall.service "${pkgdir}/usr/lib/systemd/system/hpfall.service"
-} \ No newline at end of file
+}