summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorblackhole2019-04-27 10:04:13 +0200
committerblackhole2019-04-27 10:04:13 +0200
commit2f6161684966753292c05acf7aeb6ef2c67fe837 (patch)
tree60fc58b81a3efa1d8a7f1c00f9b8773822359f5d /PKGBUILD
downloadaur-2f6161684966753292c05acf7aeb6ef2c67fe837.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aad18af631b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+
+pkgname=hqplayer
+_debpkgver=4.0.0-1
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="The high-end upsampling multichannel software HD-audio player"
+arch=('x86_64')
+url="http://www.signalyst.com/consumer.html"
+license=('custom')
+depends=('glibc' 'gcc-libs' 'libx11' 'qt5-base' 'qt5-script' 'qt5-quickcontrols' 'qt5-quickcontrols2' 'qt5-svg' 'qt5-declarative' 'qt5-graphicaleffects' 'libmicrohttpd' 'alsa-lib' 'flac')
+optdepends=('evince: hqplayer manual reading')
+source=("http://www.signalyst.com/bins/hqplayer4desktop_"$_debpkgver"_amd64.deb")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir"
+ bsdtar xf data.tar.xz -C "$pkgdir"
+ install -Dm644 "$pkgdir/usr/share/doc/hqplayer4desktop/copyright" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ rm "$pkgdir/usr/share/doc/hqplayer4desktop/copyright"
+}