summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVladimir Luzan2021-12-11 00:25:19 +0300
committerVladimir Luzan2021-12-11 00:25:19 +0300
commita8a3dc2b86168bc04609cafaccd73649e821e96a (patch)
tree289380c3409fa42e6ad25e298e3ec771fb7b7f0b /PKGBUILD
parent27ee5ada4f8623cc87bb03fb924b404bf8ab5ae6 (diff)
downloadaur-a8a3dc2b86168bc04609cafaccd73649e821e96a.tar.gz
rolling back to 1.0 and patches from lmartinez-mirror
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 13 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ff114c5c3a7..7e103711c43e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
-# Maintainer: Vladimir Luzan <vluzan@disroot.org>
-# Contributor: Vladimir Luzan <vluzan@disroot.org>
+# Maintainer: nevadimov
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=hru
-pkgver="1.0"
-pkgrel=0
+pkgver=1.0
+pkgrel=1
pkgdesc="Filter that translates latin or cyrillic text into grunt"
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="https://git.sr.ht/~begs/hru"
-license=('WTFPL')
-depends=(
- 'libutf8proc'
- 'scdoc'
-)
-makedepends=(
- 'git'
- 'scdoc'
-)
-source=("hru::git+https://git.sr.ht/~begs/hru")
-sha512sums=("SKIP")
+license=('custom:WTFPL')
+depends=('libutf8proc' 'glibc')
+makedepends=('scdoc')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('8f2da7447ea23950e151cbd71eefc1f112d1a06acd017d485acbde937b916fea')
build() {
- cd "$srcdir/$pkgname"
- make build
+ cd "$pkgname-$pkgver"
+ make build DEPS=libutf8proc
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir" install
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}