summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-09-17 17:53:05 +0200
committerTorsten Keßler2022-09-17 17:53:05 +0200
commit7b81bd5efde297294116c728f0d305a95a3fe14f (patch)
treec06badf944318576d5b4723ed8834db19f2367b1 /PKGBUILD
parent42d9baf1ba0371ccb62f742fd77d988c3025f986 (diff)
downloadaur-7b81bd5efde297294116c728f0d305a95a3fe14f.tar.gz
upgpkg: hsakmt-roct 5.2.3-2
Use cmake template, remove heredocs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5b38ccc5573..a18a86d0d87f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,13 @@
pkgname=hsakmt-roct
pkgver=5.2.3
-pkgrel=1
+pkgrel=2
pkgdesc='Radeon Open Compute Thunk Interface'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/Installation_Guide/ROCt.html'
license=('MIT')
depends=('numactl' 'pciutils' 'libdrm')
makedepends=('cmake')
-provides=("roct-thunk-interface=$pkgver")
-replaces=('roct-thunk-interface')
_git='https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface'
source=("${pkgname}-${pkgver}.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
sha256sums=('8d313b8fd945a8d7248c00a2de9a2ee896fe77e464430a91b63400a986ec0bf0')
@@ -22,15 +20,18 @@ options=(!lto)
_dirname="$(basename "$_git")-$(basename "${source[0]}" .tar.gz)"
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/opt/rocm "$_dirname"
- make
+ cmake \
+ -Wno-dev \
+ -B build \
+ -S "$_dirname" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm
+ cmake --build build
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "$_dirname/LICENSE.md" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 /dev/stdin "$pkgdir/etc/ld.so.conf.d/$pkgname.conf" <<-EOF
- /opt/rocm/lib
-EOF
+ echo '/opt/rocm/lib' > "$pkgname.conf"
+ install -Dm644 "$pkgname.conf" "$pkgdir/etc/ld.so.conf.d/$pkgname.conf"
}