summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-12-12 11:29:15 +0100
committerTorsten Keßler2022-12-12 11:29:15 +0100
commitf4b6b5c2e76f749c4e23349febca1991a08aa5c5 (patch)
treebc304983cb57470eb56460d65b31cd996c78fcd6 /PKGBUILD
parent914ab7f9e1de0446209e43a9400c5e7315adfe53 (diff)
downloadaur-f4b6b5c2e76f749c4e23349febca1991a08aa5c5.tar.gz
upgpkg: hsakmt-roct 5.4.0-2
Remove check() function as it's not working on all platforms (needs recent AMD GPU). To check correctness of installation a simple test case is added to be called after the installation of the package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 1 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc1429026ca5..f273acc84689 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=hsakmt-roct
pkgver=5.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Radeon Open Compute Thunk Interface'
arch=('x86_64')
url='https://rocmdocs.amd.com/en/latest/Installation_Guide/ROCt.html'
@@ -31,27 +31,6 @@ build() {
cmake --build build
}
-check() {
- local _tmpdir="$(mktemp -d -p $_dirname)"
- DESTDIR="$_tmpdir" cmake --install build
-
- LIBHSAKMT_PATH="$srcdir/$_tmpdir/opt/rocm" \
- cmake \
- -B kfd-build \
- -Wno-dev \
- -S "$_dirname/tests/kfdtest" \
- -DCMAKE_BUILD_TYPE=None \
- -DLLVM_DIR=/opt/rocm/llvm/lib/cmake/llvm \
- -DCMAKE_LINK_DIRECTORIES_BEFORE=ON
- cmake --build kfd-build
-
- cd kfd-build
- # Stress tests cause system crash,
- # https://github.com/RadeonOpenCompute/ROCT-Thunk-Interface/issues/76
- LD_LIBRARY_PATH="$srcdir/$_tmpdir/opt/rocm" \
- ./run_kfdtest.sh -e "KFDMemoryTest.LargestSysBufferTest:KFDMemoryTest.BigSysBufferStressTest:KFDQMTest.CreateQueueStressSingleThreaded"
-}
-
package() {
DESTDIR="$pkgdir" cmake --install build