summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKean Sum Ooi2017-09-30 21:39:43 +0800
committerKean Sum Ooi2017-09-30 21:39:43 +0800
commit284b50db16301c2e20362003521ae73082d6ad38 (patch)
treeacee2f0089837f9e38afd65de38dc1955835fdf3 /PKGBUILD
downloadaur-284b50db16301c2e20362003521ae73082d6ad38.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83e594c56f2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: kso <keansum AT gmail DOT com>
+
+pkgname=htcap-git
+_pkgname=htcap
+pkgver=1.0.1.r36.gdcc0078
+pkgrel=1
+pkgdesc="Single Page Application (SPA) crawler by intercepting AJAX calls and DOM changes"
+arch=('x86_64' 'i686')
+url="http://htcap.org/"
+license=('GPL2')
+depends=('python2'
+ 'phantomjs'
+ 'sqlmap')
+optdepends=('arachni')
+makedepends=('git')
+install=htcap.install
+source=('git+https://github.com/segment-srl/htcap')
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ sed -i 's_#\!/usr/bin/env python_#\!/usr/bin/env python2.7_' htcap.py
+}
+
+pkgver() {
+ cd "$_pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ # adding the r and replacing '.' with '-'.
+ # eg. v1.0.1-36-gdcc0078 becomes
+ # 1.0.1.r36.gdcc0078
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/
+ mv "$_pkgname" "$pkgdir"/usr/share/
+}