summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2015-06-14 19:40:42 +0200
committerL.G. Sarmiento2015-06-14 19:40:42 +0200
commit47954ab094b1a84d4d733350a1e3d9cbaf6b4703 (patch)
treed4116f80a446667cad73f7781b73b7fb221a73fb /PKGBUILD
downloadaur-47954ab094b1a84d4d733350a1e3d9cbaf6b4703.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82c554dec97f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: L.G. Sarmiento (Pico) <Luis.Sarmientop@nuclear.lu.se>
+pkgname=htmlize-git
+pkgver=20150122
+pkgrel=1
+pkgdesc="Convert buffer text and decorations to HTML"
+url="http://fly.srk.fer.hr/~hniksic/emacs/htmlize.el.cgi"
+arch=('any')
+license=('GPL2')
+depends=('emacs')
+makedepends=('git')
+
+#source=("http://fly.srk.fer.hr/~hniksic/emacs/htmlize.el.cgi")
+#md5sums=('4c455a6daea159404aafb1a02611177b')
+#it doesn't seem to do git anymore
+_gitroot='http://fly.srk.fer.hr/~hniksic/emacs/htmlize.git'
+_gitname=${pkgname}
+
+package() {
+ cd ${srcdir}
+ if [ -d ${srcdir}/$_gitname ]; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+# msg "GIT checkout done or server timeout"
+ install -m644 -D ${srcdir}/$_gitname/htmlize.el $pkgdir/usr/share/emacs/site-lisp/htmlize.el
+}