summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVinícius dos Santos Oliveira2019-01-04 10:54:23 -0200
committerVinícius dos Santos Oliveira2019-01-04 10:54:23 -0200
commit0559d2653ec3aac99c14659d9fcb8af90512c8ff (patch)
tree6eff29472d71b5dfa8473d3ef11e82df11727aad /PKGBUILD
parent82103f35da64e22622c7507f9e394c2eecd1bf70 (diff)
downloadaur-0559d2653ec3aac99c14659d9fcb8af90512c8ff.tar.gz
http-prompt 1.0.0-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d23806302ee..db22342c281d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,35 @@
# Maintainer: wenLiangcan <boxeed at gmail dot com>
+# Maintainer: vinipsmaker <vini.ipsmaker@gmail.com>
pkgbase=('http-prompt')
pkgname=('http-prompt')
_module='http-prompt'
-pkgver='0.10.1'
+pkgver='1.0.0'
pkgrel=1
pkgdesc="An interactive HTTP command-line client"
url="https://github.com/eliangcs/http-prompt"
-depends=('python' 'python-click' 'httpie' 'python-prompt_toolkit' 'python-pygments' 'python-six' 'python-parsimonious' 'python-pip')
+depends=('python'
+ 'python-click'
+ 'httpie'
+ 'python-prompt_toolkit1'
+ 'python-pygments'
+ 'python-six'
+ 'python-parsimonious'
+ 'python-pip')
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/h/http-prompt/http-prompt-${pkgver}.tar.gz")
-md5sums=('7ecc8062ee2d8b8d42757019df6a2350')
+md5sums=('aee6b913be3190f66f8765281ce3d8f0')
+
+prepare() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ sed -e 's/prompt_toolkit/prompt_toolkit1/g' -i http_prompt/*.py
+}
package() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
+ sed -e 's/prompt-toolkit/prompt-toolkit1/g' -i \
+ "${pkgdir}/usr/lib/python3.7/site-packages/http_prompt-1.0.0-py3.7.egg-info/requires.txt"
}
-