summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen2015-06-09 16:27:29 +0800
committerAllen2015-06-09 16:27:29 +0800
commitcfe45265a44c7430a4b4195b0109a5e2012a4713 (patch)
treef4a8650011b7f23eeb20fccc5a443e0391fd73b1 /PKGBUILD
downloadaur-cfe45265a44c7430a4b4195b0109a5e2012a4713.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ef541f5525c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Joel Sevilleja Febrer Joel7987[at].gmail.com
+# Maintainer: Allen Choong <allencch at hotmail dot com>
+
+pkgname=httpcomponents-client
+pkgver=4.4.1
+pkgrel=1
+pkgdesc="A HTTP/1.1 compliant HTTP agent implementation based on HttpCore"
+arch=('any')
+url="http://hc.apache.org/"
+license="Apache"
+depends=('java-runtime')
+conflicts=('')
+source=(http://www.apache.org/dist/httpcomponents/httpclient/binary/${pkgname}-${pkgver}-bin.tar.gz)
+md5sums=('edb03c31c84f7c509650768ecd57b0fb')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/lib
+ mkdir -p ${pkgdir}/usr/share/java/${pkgname}
+ chmod +r *.jar
+ cp *.jar ${pkgdir}/usr/share/java/${pkgname}
+}
+