summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander 'chron' Kempen2017-07-04 15:34:50 +0200
committerAlexander 'chron' Kempen2017-07-04 15:34:50 +0200
commit09e1931aa92a1681c3436495780b23ec3a4a9ecb (patch)
tree802eb2451dee392b6c42bfb2dad069064d45cc05 /PKGBUILD
downloadaur-09e1931aa92a1681c3436495780b23ec3a4a9ecb.tar.gz
First stable version, dropping the -git package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af27018e8be5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer chron <chron at posteo dot de>
+pkgname=httpdiff
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Perform the same request against two HTTP servers and diff the results"
+arch=("i686" "x86_64")
+url="https://github.com/jgrahamc/httpdiff"
+license=("GPL2")
+makedepends=("git" "go")
+source=("httpdiff::git+https://github.com/jgrahamc/httpdiff.git#tag=v1.0.0")
+
+sha256sums=("SKIP")
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ make all
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}
+ install -Dm 755 "${srcdir}/${_pkgname}/httpdiff" "${pkgdir}/usr/bin/httpdiff"
+ install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}