summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOwen Trigueros2023-01-14 13:18:51 +0100
committerOwen Trigueros2023-01-14 13:18:51 +0100
commitf7cbcbab9e3996e01cf77c628595437cd99f4449 (patch)
tree66835db7b80f464ffcfc281e3de9fb1af61157ff /PKGBUILD
parent94aa7b8637a24f0337c352fd441d785c2a0cd60f (diff)
downloadaur-f7cbcbab9e3996e01cf77c628595437cd99f4449.tar.gz
upgpkg: httpdirfs 1.2.4-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 427d1a770e76..5f9ae600f336 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
pkgname=httpdirfs
-pkgver=1.2.3
-pkgrel=2
+pkgver=1.2.4
+pkgrel=1
pkgdesc="A filesystem which allows you to mount HTTP directory listings"
arch=('x86_64')
url="https://github.com/fangfufu/httpdirfs"
license=('GPL')
depends=('gumbo-parser' 'fuse2' 'curl' 'expat')
+makedepends=('help2man' 'doxygen')
source=("$pkgname-$pkgver.tar.gz::https://github.com/fangfufu/$pkgname/archive/$pkgver.tar.gz")
-md5sums=("32c2fb2e30e55b6e42ac6a54c638ba47")
+md5sums=("f6d1e69f2458c9858cf1f44972a8ebc9")
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make man
+ make doc
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make prefix=/usr DESTDIR="$pkgdir" install
+ cd "$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir" install
}