summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSébastien Luttringer2017-03-05 14:25:32 +0100
committerSébastien Luttringer2017-03-05 14:25:32 +0100
commitdbd71541c1e7a78e36ea7481759a31b6f7deac2c (patch)
treea7163fdb064cb6e02ba9a78fbbae7756d8eb7772 /PKGBUILD
downloadaur-dbd71541c1e7a78e36ea7481759a31b6f7deac2c.tar.gz
Initial commit
moved from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26cd6f7ed6ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id: PKGBUILD 207393 2017-01-14 18:17:11Z seblu $
+# Maintainer: Sébastien Luttringer <seblu@archlinux.org>
+# Contributor: Essien Ita Essien <me@essienitaessien.com>
+# Contributor: Peter Baldwin <bald_pete@hotmail.com>
+
+pkgname=httperf
+pkgver=0.9.0
+pkgrel=8
+pkgdesc='A tool for measuring web server performance.'
+arch=('i686' 'x86_64')
+license=('GPL2')
+url='http://code.google.com/p/httperf'
+depends=('openssl')
+source=("http://$pkgname.googlecode.com/files/$pkgname-$pkgver.tar.gz"
+ 'use-SSLv23_client_method.patch')
+md5sums=('2968c36b9ecf3d98fc1f2c1c9c0d9341'
+ '4b7cd4bd707c322f73333e34f0302b76')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: