summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxduugu2016-07-01 13:26:12 +0200
committerxduugu2016-07-01 13:26:12 +0200
commitde9b4fa5a7f6465037caf31ae54e0a60d96b4480 (patch)
tree9e8d27a3ce4fa1ff2bf7b52394500505ab719034 /PKGBUILD
downloadaur-de9b4fa5a7f6465037caf31ae54e0a60d96b4480.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8690c222d951
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=httpie-unixsocket-git
+pkgver=r10.4fd1413
+pkgrel=1
+pkgdesc="UNIX socket transport plugin for HTTPie"
+arch=('any')
+url="https://github.com/msabramo/httpie-unixsocket"
+license=('custom:BSD')
+depends=('httpie' 'python-requests-unixsocket')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=('git+https://github.com/msabramo/httpie-unixsocket.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-*}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}