summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÉtienne Deparis2015-08-10 13:01:23 +0200
committerÉtienne Deparis2015-08-10 13:01:23 +0200
commitd652299ef7a0a9f4e4421fc228df996915f01cca (patch)
tree2f17b6d219e09f8cc48477a4a46018098cb3a4a6 /PKGBUILD
downloadaur-d652299ef7a0a9f4e4421fc228df996915f01cca.tar.gz
Take back hubic on AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd1b637a9ff8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Étienne Deparis <etienne [at] depar [dot] is>
+# Creator: casimir <aur.casimir-lab.net>
+
+pkgname=hubic
+pkgver=2.1.0
+_pkgbuildver=53
+pkgrel=55
+pkgdesc="Synchronization service provided by OVH."
+arch=('any')
+url="https://hubic.com/"
+license=('custom')
+provides=('hubic')
+depends=('mono>=2.10')
+install=hubic.install
+changelog=CHANGELOG
+source=(http://mir7.ovh.net/ovh-applications/hubic/hubiC-Linux/${pkgver}/hubiC-Linux-${pkgver}.${_pkgbuildver}-linux.tar.gz)
+sha1sums=('67c7a51325271945414f2c3c61eb371a908ea43b')
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/usr" RUNTIME_PREFIX="/usr" DBUSSERVICE_DIR="$pkgdir/usr/share/dbus-1/services" install
+ install -dm 755 $pkgdir/usr/share/licenses/hubic
+ mv $pkgdir/usr/share/doc/hubic/copyright $pkgdir/usr/share/licenses/hubic/LICENSE
+ install -Dm 644 doc/Contrat_hubiC_2013.pdf $pkgdir/usr/share/licenses/hubic/CGU-fr_FR.pdf
+}