summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-07-01 22:44:28 +0200
committerLukáš Jirkovský2015-07-01 22:44:28 +0200
commit082b000d803c7cf9670905ca54be1b62a1067e7c (patch)
treeb82212b529fb753f57bd89950374b3c087612ad8 /PKGBUILD
downloadaur-082b000d803c7cf9670905ca54be1b62a1067e7c.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71d22d859d24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=hugin-hg
+pkgver=7055.ae8cb92b02e5
+pkgrel=1
+pkgdesc="A frontend to the panorama-tools"
+arch=('i686' 'x86_64')
+url="http://hugin.sourceforge.net/"
+license=('GPL')
+depends=('openexr' 'exiv2' 'wxgtk' 'boost-libs' 'libpano13>=2.9.19' 'python2' \
+ 'lensfun' 'glew' 'enblend-enfuse' 'perl-exiftool' 'desktop-file-utils')
+makedepends=('mercurial' 'cmake' 'boost' 'swig')
+optdepends=('autopano-sift-c: automatic control point generator (obsolete)')
+provides=('hugin')
+conflicts=('hugin')
+install=hugin.install
+source=('hg+http://hg.code.sf.net/p/hugin/hugin')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/hugin"
+ echo $(hg identify -n).$(hg identify -i)
+}
+
+build() {
+ cd "$srcdir/hugin"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_HSI=ON \
+ -DCMAKE_SHARED_LINKER_FLAGS="-lpthread" \
+ .
+ make
+}
+
+package() {
+ cd "$srcdir/hugin"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: