summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorg Schlisio2016-05-18 16:53:25 +0200
committerGeorg Schlisio2016-05-18 16:53:25 +0200
commit5b1174281a422c81881cb3eab199d5b3cf23f110 (patch)
tree60aa33f5871ae9cc15c344678a9265ebae8cee2a /PKGBUILD
downloadaur-5b1174281a422c81881cb3eab199d5b3cf23f110.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b99218f6c9d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgname=humanresourcemachine
+pkgver=2016.03.23
+pkgrel=1
+pkgdesc="Assembler programming puzzle game by the makers of WorldOfGoo - game sold separately (HumbleStore)"
+url="http://tomorrowcorporation.com/humanresourcemachine"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=("sdl2" "openal")
+source=("humblestore://HumanResourceMachine-Linux-2016-03-23.sh")
+md5sums=('ac6013284194203c4732e713dcc0f543')
+PKGEXT=.pkg.tar
+DLAGENTS+=('humblestore://usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\". Game available from HumbleStore."; exit 1')
+
+package() {
+ if [[ $CARCH == 'i686' ]]
+ then
+ install -Dm755 "$srcdir/data/x86/HumanResourceMachine.bin.x86" "${pkgdir}/opt/humanresourcemachine/HumanResourceMachine.bin"
+ #cp -R "${srcdir}/data/x86/lib/"* "${pkgdir}/usr/lib/"
+ elif [[ $CARCH == 'x86_64' ]]
+ then
+ install -Dm755 "$srcdir/data/x86_64/HumanResourceMachine.bin.x86_64" "${pkgdir}/opt/humanresourcemachine/HumanResourceMachine.bin"
+ #cp -R "${srcdir}/data/x86_64/lib64/"* "${pkgdir}/usr/lib/"
+ fi
+
+ # copy files
+ install -Dm644 "$srcdir/data/noarch/LICENSE.txt" "$pkgdir/usr/share/licenses/humanresourcemachine/LICENSE"
+ install -Dm644 "$srcdir/data/noarch/README.linux" "$pkgdir/opt/humanresourcemachine/README"
+ install -Dm644 "$srcdir/data/noarch/icon.png" "$pkgdir/opt/humanresourcemachine/icon.png"
+ install -Dm644 "$srcdir/data/noarch/resource.pak" "$pkgdir/opt/humanresourcemachine/resource.pak"
+ cp -R "$srcdir/data/noarch/shaders" "$pkgdir/opt/humanresourcemachine/"
+
+ # starter script
+ mkdir -p "${pkgdir}/usr/bin"
+ cat >> "${pkgdir}/usr/bin/humanresourcemachine" << \here
+#!/usr/bin/bash
+cd /opt/humanresourcemachine
+HumanResourceMachine.bin
+here
+ chmod a+x "${pkgdir}/usr/bin/humanresourcemachine"
+}