summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorariasuni2020-11-23 14:55:04 +0100
committerariasuni2020-11-23 14:55:04 +0100
commit19e5e357b50879c97d541cb3c8bda7a3ef9458c9 (patch)
treea828a29ba41fafd302b83af6c051f24b548f10f4 /PKGBUILD
parent5287f0881661f31c07c414ff09c77b573bbfa61e (diff)
downloadaur-19e5e357b50879c97d541cb3c8bda7a3ef9458c9.tar.gz
generate dictionaries for Chromium/QtWebEngine
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5833d6d3c0a..94366293fe70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgbase='hunspell-fr'
pkgname=($pkgbase-{'classical','comprehensive','modern','revised'})
pkgver=6.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="French Hunspell dictionary"
arch=(any)
_base_url="https://grammalecte.net"
url="${_base_url}/home.php?prj=fr"
license=('MPL2')
+makedepends=('qt5-webengine')
conflicts=('hunspell-fr')
provides=('hunspell-fr')
source=("${_base_url}/download/fr/hunspell-french-dictionaries-v${pkgver}.zip")
@@ -58,4 +59,11 @@ _package() {
popd
install -Dm644 README_dict_fr.txt "${pkgdir}"/usr/share/doc/${pkgname}/README_dict_fr.txt
+
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
+ _filename=$(basename $_file)
+ qwebengine_convert_dict $_file "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
+ done
}