summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFran Dieguez2020-08-17 16:45:30 +0200
committerFran Dieguez2020-08-17 16:45:30 +0200
commit63feaa4467d7339568b94242307350d6693ff4c1 (patch)
treefa960ad71e242f073b0415d394eef21041be1d57 /PKGBUILD
parent62bb981228bc704055318ab60dc646e74da574f0 (diff)
downloadaur-63feaa4467d7339568b94242307350d6693ff4c1.tar.gz
Install the built dictionary in qt webengine dictionaries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea2a837af294..7c8f37136732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ arch=(any)
url="https://gitlab.com/proxecto-trasno/hunspell-gl"
license=('GPL3')
optdepends=('hunspell: the spell checking libraries and apps')
-makedepends=('scons' 'python-pyicu')
+makedepends=('scons' 'python-pyicu' 'qt5-webengine')
provides=($pkgname)
conflicts=($pkgname)
source=("${pkgname}.tar.bz2::https://gitlab.com/proxecto-trasno/hunspell-gl/-/archive/${pkgver}/hunspell-gl-${pkgver}.tar.bz2")
@@ -36,6 +36,12 @@ package(){
popd
# docs
- install -dm755 $pkgdir/usr/share/doc/$pkgname
-}
+ install -dm644 $pkgdir/usr/share/doc/$pkgname
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in "$pkgdir"/usr/share/hunspell/*.dic; do
+ _filename=$(basename $_file)
+ qwebengine_convert_dict $_file "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/${_filename/\.dic/\.bdic}
+ done
+}