summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLynuxed2023-01-26 18:05:11 -0600
committerLynuxed2023-01-26 18:05:11 -0600
commitdb9b165bba7cfec5ca961ad39240153c0aae264d (patch)
tree7e7bbd69b75a5dcbe70c0fe043eaa71af4c14739 /PKGBUILD
parent7f19e023e5c8949e75ba0cd29f5593946d67c5e0 (diff)
downloadaur-hunspell-la.tar.gz
New Maintainer, New source, Optimized BOM Removal, Installation permisions, added license location
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 25 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f565010df53c..e508ec9fc603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer: Archadept
-# Revision: 2018-04-14
-
-pkgname=hunspell-la
-pkgver=20130331
-pkgrel=3
-pkgdesc='Latin dictionary for Hunspell'
+# Maintainer: Lynuxed
+# Contributor: Archadept <flame-droid at gmx dot com>
+# Revision: 2023-01-26
+
+pkgname="hunspell-la"
+pkgver="2013.03.31"
+pkgrel="4"
+pkgdesc='Latin hunspell dictionary'
arch=('any')
url="https://extensions.libreoffice.org/extensions/latin-spelling-and-hyphenation-dictionaries"
license=('GPL')
optdepends=('hunspell: the spell checking libraries and apps')
-source=('https://extensions.libreoffice.org/extensions/latin-spelling-and-hyphenation-dictionaries/2013.03.31/@@download/file/dict-la_2013-03-31.oxt')
+source=('https://extensions.libreoffice.org/assets/downloads/z/dict-la-2013-03-31.oxt')
md5sums=('46674c8e9985b97e3f71555ed83a90cd')
prepare() {
@@ -18,27 +19,26 @@ prepare() {
# However, some third-party applications can be affected. For example:
# https://bugs.launchpad.net/ubuntu/+source/hunspell-ru/+bug/992194
- # BOM removal
- LC_ALL=C sed -i '1s/^\xEF\xBB\xBF//' "${srcdir}/la/universal/la.dic"
- LC_ALL=C sed -i '1s/^\xEF\xBB\xBF//' "${srcdir}/la/universal/la.aff"
+ # BOM removal
+ LC_ALL=C sed -s -i '1s/^\xEF\xBB\xBF//' ${srcdir}/la/universal/*
}
package() {
- cd "${srcdir}/la/universal"
-
- # Hunspell dictionary
- install -Dm644 la.dic ${pkgdir}/usr/share/hunspell/la_LA.dic
- install -Dm644 la.aff ${pkgdir}/usr/share/hunspell/la_LA.aff
-
- # MySpell links
- install -dm755 ${pkgdir}/usr/share/myspell/dicts
- pushd ${pkgdir}/usr/share/myspell/dicts
- for file in ${pkgdir}/usr/share/hunspell/*; do
- ln -sv /usr/share/hunspell/$(basename ${file}) .
- done
+
+ #copy hunspell
+ cd "${srcdir}"/la/universal
+ install -dm755 "${pkgdir}"/usr/share/hunspell
+ install -m644 -t "${pkgdir}"/usr/share/hunspell la.aff la.dic
+
+ # myspell symlinks
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "${pkgdir}"/usr/share/myspell/dicts
+ for file in "${pkgdir}"/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/"$(basename "${file}")" .
+ done
popd
- # Docs
- install -Dm644 "${srcdir}/la/README_la.txt" "${pkgdir}/usr/share/doc/${pkgname}/README_la.txt"
+ # license
+ install -Dm644 "${srcdir}"/la/README_la.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}