summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreugene2020-05-31 23:57:07 +0000
committereugene2020-05-31 23:57:07 +0000
commitdf3cee1f8e7b18221bbcd3041c8c4053ab9d9e20 (patch)
tree36d4221febc87b184b2e360e651d1a141107b063 /PKGBUILD
parente9079e8c416f20bfba0bb847724c80607b0f667e (diff)
downloadaur-df3cee1f8e7b18221bbcd3041c8c4053ab9d9e20.tar.gz
update to 5.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c25f1855b97..02690b47b5c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,21 @@
# Contributor: Rax Garfield <admin at dvizho.ks.ua>
pkgname=hunspell-uk
-pkgver=4.9.0
+pkgver=5.0.1
pkgrel=1
pkgdesc="Ukrainian spelling dictionary"
arch=('any')
url='https://github.com/brown-uk/dict_uk'
license=('MPL')
optdepends=('hunspell: the spell checking libraries and apps')
-source=("https://github.com/brown-uk/dict_uk/releases/download/v${pkgver}/hunspell-uk_UA.zip"
- "https://github.com/brown-uk/dict_uk/releases/download/v${pkgver}/chrome_dict_uk-UA-${pkgver}.zip")
-sha256sums=('da763d82508b745565ebb15c79e1e9ebe7115be201a263c92fa61777bb5367c0'
- '860c9b9341f62520a3dc1ebfbe8d4e82703f123be889e67dd17f5361a6222adb')
+makedepends=('qt5-webengine')
+source=("https://github.com/brown-uk/dict_uk/releases/download/v${pkgver}/hunspell-uk_UA_${pkgver}.zip")
+sha256sums=('b59189ef0f71a6b7693c0343afc7ecd3472459671ba42e4e372a4472ba39fc1c')
package() {
install -dm755 "$pkgdir"/usr/share/hunspell
install -m644 uk_UA.* "$pkgdir"/usr/share/hunspell
- # Install webengine dictionaries
- install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries
- install -m644 uk-UA*.bdic "$pkgdir"/usr/share/qt/qtwebengine_dictionaries
-
# myspell symlinks
install -dm755 ${pkgdir}/usr/share/myspell/dicts
pushd ${pkgdir}/usr/share/myspell/dicts
@@ -29,4 +24,12 @@ package() {
ln -sv /usr/share/hunspell/$(basename ${file}) .
done
popd
+
+ # Install webengine dictionaries
+ install -d "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/
+ for _file in *.dic; do
+ _filename="$(basename $_file)"
+ sed -i '/^IGNORE/d' "${_file/\.dic/\.aff}"
+ qwebengine_convert_dict "$_file" "$pkgdir"/usr/share/qt/qtwebengine_dictionaries/"${_filename/\.dic/\.bdic}"
+ done
}